Our email provider Mailgun's having issues
Incident Report for Helpwise
Resolved
This incident has been resolved.
Posted May 31, 2024 - 09:27 UTC
Update
We are continuing to monitor for any further issues.
Posted May 31, 2024 - 08:35 UTC
Update
We are continuing to monitor for any further issues.
Posted May 31, 2024 - 08:20 UTC
Monitoring
We're currently monitoring an issue with our Email provider Mailgun - https://status.mailgun.com/incidents/30w5l1zqcw5r

Incoming Email forwarding, Outgoing delivery (when using Helpwise in outgoing settings), login MFA codes and email notifications are impacted
Posted May 31, 2024 - 08:18 UTC
This incident affected: Email Services (Incoming Email Forwarding, Outgoing Email Delivery) and Platform (Notifications, Login).