The problem seems to be caused by the underlying dependencies from Helpwise's AWS infrastructure in us-east-2 region. We're currently monitoring the situation.
Posted Oct 07, 2024 - 20:02 UTC
Investigating
We are currently investigating this issue.
Posted Oct 07, 2024 - 19:50 UTC
This incident affected: Email Services (Incoming Email Forwarding, Outgoing Email Delivery, Gmail Sync, Microsoft Outlook Sync).