Not able to send emails with individual attachment size > 3 mb with Microsoft Outlook account connected for Outgoing.

Incident Report for Helpwise

Resolved

Looks like Microsoft has now fixed this. We're now not noticing this issue. We're continuing to monitor it.
Posted Apr 23, 2025 - 06:41 UTC

Identified

We've identified an issue where our system is unable to send attachment size > 3 mb with Microsoft Outlook account connected for Outgoing as Microsoft API is giving error.

We're working towards a solution to this.

In the meanwhile as a workaround for customers who have connected Outlook accounts with Helpwise. We would recommend to restrict attachment sizes to less than 3MB as a workaround.
Posted Apr 17, 2025 - 18:48 UTC
This incident affected: Email Services (Microsoft Outlook Sync).