Webap, inbox and outlook sync functionalities and performance is degraded.

Incident Report for Helpwise

Resolved

This incident has been resolved.
Posted Mar 02, 2025 - 02:05 UTC

Update

Microsoft issues seems to have improved. Please reconnect your Microsoft account with Helpwise if you see the reconnect option in the Inbox.
Posted Mar 01, 2025 - 22:04 UTC

Monitoring

Microsoft has confirmed the incident. Here are more details - https://admin.cloud.microsoft/?#/servicehealth/:/alerts/MO1020913. Only customers using Outlook sync or sending outbound emails using "Connect with Microsoft" might face issues using the service.
Posted Mar 01, 2025 - 21:52 UTC

Identified

The issue has been isolated to Outlook services acting slow and causing bottlenecks. We've isolated the issue to Outlook sync. Webapp and inbox should be operational now.
Posted Mar 01, 2025 - 21:42 UTC

Investigating

We are currently investigating this issue.
Posted Mar 01, 2025 - 21:22 UTC
This incident affected: Platform (Helpwise Web App, Helpwise Inbox) and Email Services (Microsoft Outlook Sync).