Relaying denied error on incoming email forwarding

Incident Report for Helpwise

Resolved

We're no longer noticing these errors. If you're still facing this please reach out to our chat support or help@helpwise.io.

Unfortunately, we wouldn't be able to recover emails which weren't able to process due to this incident as they never reached our system. Our team would be reviewing how we can streamline this further.
Posted Jun 26, 2023 - 09:27 UTC

Update

It seems like we're not receiving any errors now, our team is continuing to monitor this.
Posted Jun 26, 2023 - 09:00 UTC

Update

It seems like the error rate is now further reduced but we're not noticing errors in our monitoring systems now.
Posted Jun 26, 2023 - 08:48 UTC

Update

It seems like the error rate is now further reduced but we're not noticing errors in our monitoring systems now.
Posted Jun 26, 2023 - 08:48 UTC

Update

It seems like the error rate is now reduced but we're still noticing errors.
Posted Jun 26, 2023 - 08:15 UTC

Monitoring

We can confirm this error is coming from Mailgun. Our team's currently monitoring the situation
Posted Jun 26, 2023 - 07:20 UTC

Investigating

It seems like our underlying email provider Mailgun's having issues while handling incoming messages on our forwarding addresses. Our team's currently reviewing this.
Posted Jun 26, 2023 - 07:16 UTC
This incident affected: Email Services (Incoming Email Forwarding).