Forwarding addresses ending with mail.helpwisemail.com are not working
Incident Report for Helpwise
Resolved
We have fixed this with our email provider. @mail.helpwisemail.com should now be fully operational. If you are still facing any issues please reach out to us at help@helpwise.io or chat support
Posted Oct 16, 2024 - 18:19 UTC
Identified
We're identified an issue with our underlying provider due to which forwarding to addresses @mail.helpwisemail.com are not working. Forwarding addresses ending with @mail1.helpwisemail.com, @mail2.helpwisemail.com and @mail3.helpwisemail.com are working fine.

Workaround:
Please change @mail.helpwisemail.com to @mail1.helpwisemail.com. Reach out to help@helpwise.io or chat support if you need more help getting it to work.
Posted Oct 16, 2024 - 03:35 UTC
This incident affected: Email Services (Incoming Email Forwarding).