Microsoft 365 errors and delay

Incident Report for Helpwise

Resolved

This incident has been resolved.
Posted Nov 26, 2024 - 04:31 UTC

Update

We're continuing to monitor our systems. Microsoft's still working on fixing this issue.
Posted Nov 25, 2024 - 16:10 UTC

Monitoring

Customers using MS365 sync would be seeing high error rates and delay in email sync

Live updates on X - https://x.com/MSFT365Status?ref_src=twsrc%5Egoogle%7Ctwcamp%5Eserp%7Ctwgr%5Eauthor

Microsoft is still investigating the issue - https://portal.office.com/Adminportal/Home#/servicehealth/:/alerts/MO941162 (You need to be an O365 admin to be able to access it)
Posted Nov 25, 2024 - 12:23 UTC
This incident affected: Email Services (Outgoing Email Delivery, Microsoft Outlook Sync).