Elevated errors from Outlook
Incident Report for Helpwise
Resolved
We're not seeing errors now in our monitoring systems.
Posted Jun 05, 2023 - 16:58 UTC
Update
We're continuing to monitor this
Posted Jun 05, 2023 - 15:44 UTC
Monitoring
Our monitoring system has detected issues with Microsoft Outlook. We're receiving a very high error rate from Microsoft services.

It's also confirmed by Microsoft 365's status tweet - https://twitter.com/MSFT365Status/status/1665734492122742790?cxt=HHwWjIC80b6s8J0uAAAA
Posted Jun 05, 2023 - 15:03 UTC
This incident affected: Email Services (Outgoing Email Delivery, Microsoft Outlook Sync).