We are continuing to work with our email provider to fix this issue.
Posted Mar 13, 2025 - 14:44 UTC
Identified
We're identified an issue with our underlying provider due to which forwarding to addresses @mail3.helpwisemail.com are not working. Forwarding addresses ending with @mail.helpwisemail.com, @mail1.helpwisemail.com and @mail2.helpwisemail.com are working fine.
Workaround: Please change @mail3.helpwisemail.com to @mail1.helpwisemail.com. Reach out to help@helpwise.io if you need more help getting it to work.
Posted Mar 13, 2025 - 14:42 UTC
This incident affected: Email Services (Incoming Email Forwarding).