Issue in incoming email forwarding
Incident Report for Helpwise
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 20:33 UTC
Update
We are continuing to work on a fix for this issue. Please implement the workaround mentioned below.
Posted Nov 20, 2023 - 20:09 UTC
Identified
Emails forwarded to @mail1.helpwisemail.com are being dropped. As a workaround, If you're using email forwarding with Helpwise please change the address to @mail2.helpwisemail.com. Please contact chat support or help@helpwise.io for more information.
Posted Nov 20, 2023 - 20:07 UTC
This incident affected: Email Services (Incoming Email Forwarding).