Facing high error rate from Microsoft 365

Incident Report for Helpwise

Resolved

This incident has been resolved.
Posted Jan 25, 2023 - 11:11 UTC

Monitoring

We are continuing to investigate this issue.
Posted Jan 25, 2023 - 09:00 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2023 - 09:00 UTC

Update

We are continuing to investigate this issue.
Posted Jan 25, 2023 - 08:14 UTC

Investigating

We're facing high error rate from Microsoft 365 APIs. Here's the latest update from Microsoft 365 - https://status.office365.com/
Posted Jan 25, 2023 - 08:06 UTC
This incident affected: Email Services (Microsoft Outlook Sync).