Search is extremely slow

Incident Report for Helpwise

Resolved

This incident has been resolved.
Posted Jun 10, 2024 - 15:29 UTC

Investigating

We are currently investigating this issue.
Posted Jun 10, 2024 - 15:06 UTC
This incident affected: Platform (Search).