Inbox loading slow for some customers
Incident Report for Helpwise
Resolved
This incident has been resolved.
Posted Oct 19, 2023 - 05:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Oct 19, 2023 - 05:33 UTC
Monitoring
Our fix has been implemented and we're monitoring the results
Posted Oct 19, 2023 - 01:45 UTC
Investigating
We're currently investigating an issue where Inbox is loading slowly for some customers.
Posted Oct 18, 2023 - 22:30 UTC
This incident affected: Platform (Helpwise Inbox).